2010 Odyssey Navi not responding correctly - Honda Odyssey Owners Club Forum
Honda Odyssey Owners Club Forum

Go Back   Honda Odyssey Owners Club Forum > Honda Odyssey > Problems & Issues

OdysseyOwnersClub.com is the premier Honda Odyssey Forum on the internet. Registered Users do not see the above ads.
Reply
 
Thread Tools Display Modes
  #1  
Old 01-23-2015, 02:54 PM
charles3682000 charles3682000 is offline
Junior Member
 
Join Date: Nov 2014
Posts: 1
Default 2010 Odyssey Navi not responding correctly

I recently bought this van and love it but the Nav system is driving me crazy. I bought the 2015 map update and installed it. I program my home addy and it accepts it but the directions are very wrong. It sees my street but not the house number and the directions carry me to a wrong address. I used to have this problem in 2011 with my garmin nuvi and after a year of sending them reports, it was fixed. Also my map app on my iphone finds it as well. When I follow the manual to edit address by using current position it shows house # 250 and I am on a dead end with house # 198. I would really like to fix this if anyone can help...Thanks
Reply With Quote
Sponsored Links
Advertisement
 
Reply

Tags
map, navi

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -5. The time now is 05:35 AM.


Powered by vBulletin® Copyright ©2000 - 2020, vBulletin Solutions, Inc.
vBulletin Security provided by vBSecurity v2.2.2 (Pro) - vBulletin Mods & Addons Copyright © 2020 DragonByte Technologies Ltd.