Knocking noise - Honda Odyssey Owners Club Forum
Honda Odyssey Owners Club Forum

Go Back   Honda Odyssey Owners Club Forum > Honda Odyssey > 2005-2010 (3rd Gen) Official Specs, Features, Etc.

OdysseyOwnersClub.com is the premier Honda Odyssey Forum on the internet. Registered Users do not see the above ads.
Reply
 
Thread Tools Display Modes
  #1  
Old 05-03-2018, 04:45 PM
ujschrock76 ujschrock76 is offline
Junior Member
 
Join Date: May 2018
Posts: 1
Default Knocking noise

My 2007 Honda Odyssey has this strange knocking sound when I first start the engine. When I rev up the engine, or as the engine warms up, it mostly goes away. My oil is good and full. My belts and pulleys seem fine. The noise seems to come from the top of the engine, but I don't know for sure. Has anyone heard of this? Thanks
Reply With Quote
Sponsored Links
Advertisement
 
  #2  
Old 05-10-2018, 09:55 AM
StockOdy StockOdy is offline
Junior Member
 
Join Date: Jun 2010
Posts: 7
Default

My service tech tells me when my 2015 starts it only runs and idles on 3 cylinders (to save fuel). It shakes just a little then smooths out but no knocking. If no engine light, no sweat? Good Luck
Reply With Quote
  #3  
Old 05-15-2018, 03:27 PM
k9sar k9sar is offline
Junior Member
 
Join Date: Jul 2013
Posts: 16
Default

knock or a peck? A top engine noise that goes away once it runs for a little bit is usually a collapsed lifter and the delay is oil pumping into it. Oil retention ball internal to it may be dirty and not seal properly. Not a problem but you could run a good detergent oil or even do a motor flush to try to dissolve any deposits. May work. I personally wouldn't worry.... unless it's not a lifter noise.
__________________
- New to me 2007 Odyssey EX
- 1995 Pathfinder SE/Offroad
- 2005 Pathfinder SE/Offroad
- RIP 1999 Grand Caravan
Reply With Quote
 
  #4  
Old 07-31-2019, 10:37 PM
tesims tesims is offline
Junior Member
 
Join Date: Jul 2019
Posts: 1
Default

Quote:
Originally Posted by ujschrock76 View Post
My 2007 Honda Odyssey has this strange knocking sound when I first start the engine. When I rev up the engine, or as the engine warms up, it mostly goes away. My oil is good and full. My belts and pulleys seem fine. The noise seems to come from the top of the engine, but I don't know for sure. Has anyone heard of this? Thanks
Were you ever able to figure out what was happening?
Reply With Quote
  #5  
Old 10-08-2019, 11:56 AM
ih8spm ih8spm is offline
Junior Member
 
Join Date: Oct 2019
Posts: 5
Default

Sounds Ike a bad hydraulic tensioner on the timing belt.

Sent from my SM-N960U using Tapatalk
Reply With Quote
Sponsored Links
Advertisement
 
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -5. The time now is 09:30 AM.


Powered by vBulletin® Copyright ©2000 - 2019, vBulletin Solutions, Inc.
vBulletin Security provided by vBSecurity v2.2.2 (Pro) - vBulletin Mods & Addons Copyright © 2019 DragonByte Technologies Ltd.